How do I burn subtitles onto a video track?

InqScribe generates text-based subtitles for QuickTime. However, there are times when you’d prefer to have those subtitles “burned” onto your video.

  • You want the subtitles to display on a video iPod, which doesn’t support text tracks.
  • You want subtitles to look exactly the same on Windows and Mac OS X, and don’t want to worry about font size differences.

Burning Subtitles with QuickTime Pro

Note: Due to security risks, we no longer recommend QuickTime for Windows users (more on this subject here).

You can use QuickTime 7 Pro to accomplish this (Note that QuickTime Pro 7 is a different product from the free QuickTime 10 Player. See this article for information on how to install it on Snow Leopard Mac OS X v10.6 or later). Here’s a quick walkthrough.

This is the super quick method of burning subtitles if you are trying to create a streaming video file:

  1. Create your subtitled QuickTime movie using these instructions.
  2. Open your subtitled movie in QT7 Player
  3. In the QuickTime7 Player, select File->Export->Movie to MPEG-4, set option to "Streaming - Medium"

You can just use the default options.  Alternatively, you can also export to .mov using "File->Export->Export to QuickTime Movie".

This also compresses the videos considerably.  E.g. a 20 MB mov becomes a 6 MB mp4.

If you need more control, here's the full walkthrough:

  1. Create your subtitled QuickTime movie using these instructions.
  2. Open the InqScribe-exported movie (we’ll call it example.mov). For this walkthrough, we’re assuming example.mov has three tracks: video, audio, and text (subtitles).
  3. Select Show Movie Properties from the Window menu.
  4. Select the audio track.
  5. Click the Extract button to extract the audio track to a new window.
  6. Save that window (we’ll call it audio_only.mov).
  7. Back in the Movie Properties dialog, click Delete to remove the audio track from example.mov.
  8. Use the Export command in the File menu to export example.mov (now without audio) to another format. (We’ll call this export combined.mov.) For example, you could select “Movie to QuickTime Movie” and “Broadband – Medium”. Use whatever you want for your final video encoding.
  9. Open combined.mov. This movie should have one video track with visible subtitles and no sound. (The trick here is that when QuickTime Player exports a movie without an audio track, it will combine video and text tracks. It’s like Photoshop’s “Merge Down” command for combining layers.)
  10. Now we need to add the audio back. Go to audio_only.mov, select all, and copy.
  11. Select combined.mov, make sure the selection triangle is at the start of the timeline, and use “Add to Movie” from the Edit menu. That adds the copied audio back to combined.mov.
  12. Save combined.mov as a “Self-Contained Movie.”

That’s it — you’re done.

Note regarding the video iPod format:
If you are targeting the video iPod, you need to be a bit careful. If, in step 7 above, you select “Movie to iPod”, your subtitles will be removed during the export. Because the video iPod can’t play text tracks, QuickTime Pro figures it’s being helpful and removes the subtitles for you.

You can workaround this by exporting to any other video format — preferably one that is significantly higher quality than iPod video.

Then, once you’ve got your combined.mov file, you just export that using the “Movie to iPod” setting, and you should be OK.

Burning Subtitles without QuickTime Pro


If you don't have QuickTime Pro, you can use free alternatives to burn in your subtitles. Read more about these online tools in our InqScribe blog below:
http://blogs.inquirium.net/inqscribe/2015/04/subtitle-burn-in-tools/

Feedback and Knowledge Base