How do I create a custom FCP 7 XML Export Template?

To import transcripts into FCP 7 as subtitles, you'll need an XML template that defines the look of your subtitles.

InqScribe comes with a bare bones default XML template to get you started, but in most cases, you'll want to create your own template that matches your frame rate and video standard (NTSC vs PAL).

Here are instructions for creating a custom template for FCP 7.


CREATING A CUSTOM FCP XML TEMPLATE

I. Set FCP video format

In order to generate a template in the appropriate video format, we need to match the video format of the sequence to the clip that you want to insert the subtitles into.  

First we're going to figure out the video format of your clip:

  1. Start Final Cut Pro 7
  2. Open your project
  3. Select your clip
  4. Ctrl-click and select "Item Properties->Format..." from the popup menu.
  5. Write down the key settings. For example, when we worked on our screencast video, our settings were:
    1. Vid Rate: 30 fps
    2. Frame Size: 640x400
    3. Compressor: H.264
    4. Pixel Aspect: Square
    5. Field Dominance: None

II. Create a FCP Sequence

In FCP, create a new sequence.  This will serve as the import template to be used in InqScribe.

  1. Start FCP 7
  2. Select File->New->Sequence.  It should be called something like "Sequence 1" by default.
  3. Rename it so that it's obvious that it's going to be an InqScribe template.  For example, "640x400_30fps_Template", or "HDV - 1080p30" to match an existing Sequence Preset name.  You're likely to re-use this template for future projects, so it might be useful to give it a name that's descriptive of the format.
Now set the format of the new sequence to match the format of your clip.
  1. Ctrl-click the sequence and select "Item Properties->Format..." from the popup menu.
  2. If you're using a Sequence Preset, click on "Load Sequence Preset" and select the appropriate preset.  Otherwise, edit the the settings to match your clip.  For example, 
    1. Frame Size: 640x400
    2. Aspect Ratio: Custom
    3. Pixel Aspect Ratio: Square
    4. Editing Timebase: 30
    5. Field Dominance: None
    6. Compressor: H.264
  3. Click OK to close the Sequence Settings window.
  4. Double click on the Sequence to open it.

III. Create a new Text Generator

Add a single Text Generator and adjust this text generator's attributes (font, size, position, etc.) to suit your needs.

  1. In the "Browser" window in the upper left, click on the "Effects" tab.
  2. Open "Video Generators" folder by clicking on the disclosure triangle.
  3. Open the "Text" tab by clicking on the disclosure triangle.
  4. Double click on the Video Generators:Text:Outline Text effect.  (We recommend using Outline Text so that light text is offset against light backgrounds).
  5. Drag the "Video" tab in the "Viewer: Outline Text" window away from the window to create a separate Video window.  This reveals the "Controls" tab where you can set the text characteristics.
  6. Set the text characteristics.  We recommend setting the following items:
    1. Font: Helvetica
    2. Style: Plain
    3. Size: 24
    4. Line Width: 3
    5. LIne Softness: 50
    6. Center: 0, 200
    7. Text Color: Yellow
    8. Line Color: Black
  7. If you need the subtitle to appear on more than one line, make sure your text generator can support more than one line (otherwise only the first line will be displayed when you import from InqScribe).
  8. Drag the Outline Text video generator from the "Browser: Effects" window onto the sequence timeline.
  9. Save the sequence for future use

IV. Export the Sequence to an XML Template

In FCP, select the sequence (and just the sequence) and export it as an XML version 1 file (InqScribe can handle FCP XML version 1, 2, and 3 files, but practically there's no difference in terms of subtitle support.)

  1. In the "Browser" window in the upper left, ctrl-click on the "Sequence 1" or "640x400_30fps_Template" you just created and select "Export->XML..."
  2. Select "Apple XML Interchange Format, version 1".
  3. Click OK.
  4. You may be prompted to save the project.
  5. You'll then be prompted to save the XML file.  For the sake of clarity, let's call it "MyInqScribeTemplate.xml"

V. Import into InqScribe

  1. In InqScribe, open your transcript.
  2. Select File > Export > Final Cut Pro XML... to bring up the export dialog. In the dialog, click the "Load From File..." button and select the XML file that was just exported from FCP ("MyInqScribeTemplate.xml").
  3. Choose a target file, and click the Export button. InqScribe scans your XML file looking for potential template generators. If it can't find any, it'll complain. Otherwise, it grabs the first one that it can find. InqScribe then uses this template generator item to create as many new generators as there are subtitles in your transcript, and exports a new XML file.

VI. Import the XML into FCP

  1. Now go back to FCP and import this new XML file into your project.
  2. Start FCP
  3. Go to File->Import->XML...
  4. Select the export.html file you just exported from InqScribe.
  5. Leave the settings to their defaults and click OK.
  6. The newly imported sequence should be named something like "Sequence 1_InqScribe" or "640x400_30fps_Template_InqScribe".  InqScribe automatically tacks on the "_InqScribe" to the sequence name.
  7. If you haven't already, create a new sequence with your clip, and then drag the exported InqScribe sequence into the clip timeline.
  8. Voila!  The subtitles should appear on top of the video.
If you need to change the appearance of the subtitles, just go back to your original template sequence and modify the sample text generator there. Then export that sequence, and repeat this process.

TIPS

Feedback and Knowledge Base